AdGuard DNS - DNS resolution issues in Singapore

Incident Report for AdGuard

Resolved

The fix has been deployed. According to our monitoring tools, the DNS service is operating normally. We will continue to monitor the situation.
Posted Sep 25, 2026 - 18:05 UTC

Identified

At the moment the fix is being deployed, we will continue to monitor the performance.
Posted Sep 25, 2026 - 17:07 UTC

Investigating

We're currently working on a fix
Posted Sep 25, 2026 - 14:18 UTC
This incident affected: AdGuard DNS.