AdGuard DNS - routing issues

Incident Report for AdGuard

Resolved

We applied manual routing adjustments to stabilize the load. No downtime was observed during the incident.
Posted Apr 01, 2026 - 13:03 UTC

Investigating

Due to global traffic rerouting in Southeast Asia, some AdGuard DNS users may experience increased DNS resolution times.

We are monitoring the situation and working to mitigate the impact.
Posted Apr 01, 2026 - 11:16 UTC
This incident affected: AdGuard DNS.