AdGuard DNS - DNS resolution issues in Singapore

Incident Report for AdGuard

Resolved

Issue was resolved
Posted Sep 24, 2026 - 17:40 UTC

Identified

Servers are stabilized, we are currently monitoring stability
Posted Sep 24, 2026 - 16:18 UTC

Investigating

We are investigating DNS resolution issues in Singapore location
Posted Sep 24, 2026 - 14:59 UTC
This incident affected: AdGuard DNS.