AdGuard DNS - query log delay

Incident Report for AdGuard

Resolved

This incident has been resolved. We will add postmortem soon
Posted Sep 24, 2025 - 19:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2025 - 16:39 UTC

Update

All missing logs will become visible in the next 90 minutes
Posted Sep 24, 2025 - 14:03 UTC

Update

All logs for 23.09.2025 will be refilled
Posted Sep 24, 2025 - 12:55 UTC

Update

All missing logs are now visible in UI. We are working on a deduplication of 23.09.2025 logs
Posted Sep 24, 2025 - 10:21 UTC

Update

At this moment we can confirm the following:
* No query logs were missed
* Some query logs for 23.09.2025 are delivered twice - we will implement the fix today
* Some old and new logs are shown in control panel with significant delay - we await resolving in the next 2-3 hours
Posted Sep 24, 2025 - 09:16 UTC

Identified

The issue has been identified, currently restoring missing query logs.
Posted Sep 24, 2025 - 08:04 UTC

Investigating

We're currently investigating the issue which causes a severe delay in query log updates in private AdGuard DNS service.
We presume that no logs have been lost, and they will arrive when the issue is solved.
Posted Sep 24, 2025 - 06:43 UTC
This incident affected: AdGuard DNS.