AdGuard DNS dashboard issues

Incident Report for AdGuard

Resolved

The incident has been resolved
Posted Jun 19, 2026 - 21:49 UTC

Investigating

Queries in AdGuard DNS query logs may appear delayed. We are working to restore the normal operation of the query logs.
Posted Jun 19, 2026 - 17:06 UTC
This incident affected: AdGuard DNS.