AdGuard DNS – Delay in Private DNS Log Delivery

Incident Report for AdGuard

Resolved

The incident has been resolved
Posted Jul 06, 2026 - 00:07 UTC

Update

Current logs delivery delay is up to 2 hours. We are still investigating the issue
Posted Jul 05, 2026 - 14:28 UTC

Identified

We are still investigating the issue. Logs are not being lost, but in some cases they may be delivered with a delay of around 30 minutes.
Posted Jul 05, 2026 - 11:55 UTC

Investigating

We are currently experiencing a delay in the delivery of logs for Private AdGuard DNS. Our team is investigating the issue.
Posted Jul 03, 2026 - 17:29 UTC
This incident affected: AdGuard DNS.