The issue has been resolved. All missing queue logs should now be visible on the query log page, and all stats on the dashboard should match accordingly
Posted Jun 24, 2025 - 20:46 UTC
Update
While the investigation is still ongoing, we're confident that no query logs are lost, and they are currently appearing on client's dashboard and query logs page with a delay of approximately 30 minutes.
Posted Jun 24, 2025 - 18:41 UTC
Investigating
We're currently investigating the issue of some DNS query logs not being visible on the dashboard and query log page for some clients.