AdGuard DNS - Connectivity Issues in Singapore

Incident Report for AdGuard

Resolved

Issue was resolved
Posted Nov 19, 2025 - 15:19 UTC

Update

Fix was implemented, we're monitoring now
Posted Nov 19, 2025 - 15:05 UTC

Identified

Issue was identified. We are currently working on service restore.
Posted Nov 19, 2025 - 14:58 UTC

Investigating

We are currently observing connectivity issues affecting AdGuard DNS servers in Singapore. We are working to identify and mitigate the issue.
Posted Nov 19, 2025 - 14:14 UTC
This incident affected: AdGuard DNS.