AdGuard DNS - partial unavailability in EU region

Incident Report for AdGuard

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 22:45 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2025 - 22:41 UTC

Identified

Due to some global routing issues some AdGuard DNS locations are overloaded and may have degraded performance
Posted Jun 11, 2025 - 22:17 UTC
This incident affected: AdGuard DNS.