AdGuard websites - partial unavailability

Incident Report for AdGuard

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 07:08 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 15:05 UTC

Investigating

We’re experiencing an outage affecting access to the site from EU region. The issue originates from an upstream network provider, causing intermittent failures and timeouts. Our systems are operating normally, but external connectivity is degraded.

We’re monitoring the situation and will restore full availability as soon as the upstream provider resolves the problem.
Posted Nov 18, 2025 - 11:41 UTC
This incident affected: all public.