Global connectivity issues are affecting multiple regions and causing degraded service performance.

Incident Report for AdGuard

Resolved

The incident has been resolved
Posted Dec 19, 2025 - 21:08 UTC

Investigating

We’re investigating global connectivity issues affecting multiple regions and causing degraded service performance.
Posted Dec 19, 2025 - 16:49 UTC
This incident affected: AdGuard VPN, all public, AdGuard, and AdGuard Mail.