AdGuard DNS - DNS resolution issues in London

Incident Report for AdGuard

Resolved

The incident has been resolved
Posted Aug 27, 2026 - 09:59 UTC

Identified

Some routing adjustments were made, we're currently monitoring the situation
Posted Aug 27, 2026 - 08:52 UTC

Investigating

We are experiencing DNS resolution issues in our London location due to changes in global network routing, which have caused the location to become overloaded. We are investigating the issue and working to restore normal service.
Posted Aug 27, 2026 - 07:51 UTC
This incident affected: AdGuard DNS.