AdGuard website is under a DDOS attack

Incident Report for AdGuard

Resolved

This incident has been resolved.
Posted May 16, 2025 - 17:34 UTC

Identified

We're deploying anti-DDOS measures.

By the way, this is a great moment to remind everyone that AdGuard filters are among the most popular and actively maintained in the world. They’re developed with the help of a large and passionate community, and we welcome any and all contributions. You can suggest your own filtering rules or let us know where ads are still slipping through.

Learn more in our filter repository:
👉 https://github.com/AdguardTeam/AdGuardFilters

The real strength of ad blockers lies in the community — it’s the result of the work of thousands of people. Huge thanks to everyone who’s helping make the web cleaner.
Posted May 16, 2025 - 14:50 UTC

Investigating

AdGuard website is currently under a DDoS attack and may be experiencing slow performance.

Judging by the nature of the attack, the attacker is very unhappy that AdGuard blocks ads on movie websites (likely pirated ones), as we initially observed millions of HTTP requests like:
StopUpdatingRulesForMoviesWebsites=stopedtingformovieswebsites@gmail.com

Naturally, we will continue blocking ads on such sites — and we’ll strive to do it even more quickly and effectively than before (if that’s even possible).
Posted May 16, 2025 - 14:33 UTC
This incident affected: Website & services.