AdGuard DNS - routing issues in EU region

Incident Report for AdGuard

Postmortem

At 05:00 (UTC) on August 26, due to routing changes in tier-1 backbone providers’ networks, a huge amount of traffic to AdGuard DNS from across Europe began to be routed to our Istanbul location (instead of the usual Frankfurt, London, and Amsterdam). Unfortunately, the Istanbul PoP is not capable of handling such a massive volume of traffic, as it normally only serves users from the Middle East.

However, instead of a complete outage (which we would have noticed immediately), overload protection mechanisms only started limiting user connections. This led to an “accumulation” of unresolved DNS queries on user devices. Because of this, we only discovered the incident at 06:30 and manually disabled the Istanbul location.

Immediately afterward, all accumulated user queries from the previous hour and a half were redirected to the more powerful Frankfurt PoP. Processing this backlog took about an hour, during which users could have experienced significant delays in DNS resolution.

All issues were finally resolved at 08:30

As a result of this incident, we decided to:

  • Increase the number of servers in Istanbul to handle potential traffic spikes
  • Distribute European traffic across multiple PoPs so that none of them becomes a single point of failure
  • Improve our monitoring system to detect routing issues more quickly and respond faster
Posted Aug 27, 2025 - 10:22 UTC

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 08:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2025 - 07:42 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 26, 2025 - 07:27 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 26, 2025 - 06:48 UTC
This incident affected: AdGuard DNS.