AdGuard DNS – Delay in Private DNS Log Delivery

Incident Report for AdGuard

Resolved

The incident has been resolved
Posted Jul 10, 2026 - 23:14 UTC

Investigating

We are currently experiencing a delay in the delivery of logs for Private AdGuard DNS. Our team is investigating the issue. We don't except any query logs to be lost.
Posted Jul 10, 2026 - 19:23 UTC
This incident affected: AdGuard DNS.