AdGuard DNS outage in Los Angeles
Incident Report for AdGuard
Postmortem

The issue was caused by problematic changes to AdGuard DNS software configuration. We increased GOGC variable which basically means that we exchanged RAM for CPU usage. The problem is that the configured value lead to huge RAM usage spikes and the OOM killer aborting the AdGuard DNS process in result.

Posted Aug 08, 2023 - 07:32 UTC

Resolved
The incident started at about 4:00 AM UTC and was resolved in about 40 minutes after that.
Posted Aug 08, 2023 - 04:00 UTC