Issues with Email Delivery

Incident Report for AdGuard

Resolved

The issue has been fully resolved, and the email service is back to normal. We have confirmed that no emails were lost; however, there was a slight delay in their delivery.

All queued messages have now been successfully processed. We apologize for the inconvenience.
Posted Mar 23, 2026 - 15:53 UTC

Investigating

We have detected an issue affecting our email delivery system. As this affects transactional emails (notifications, password resets, confirmations), all services are currently impacted.
Posted Mar 23, 2026 - 13:52 UTC
This incident affected: all public.